1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Troubleshooting 'Cannot locate the CD-ROM' Please insert the correct CD-ROM (HELP)!

Discussion in 'The Sims 2' started by rockout364, Dec 26, 2007.

  1. rockout364

    rockout364 rockout!

    'Cannot locate the CD-ROM' Please insert the correct CD-ROM (HELP)!

    I installed "The Sims 2" CD-ROM on my PC and it installed correctly, but when I insert the CD-ROM or click on the Sims 2 Icon it pops up this message:

    Cannot locate the CD-ROM
    Please insert the correct CD-ROM, select ok, and restart application


    I have inserted the correct Sims 2 CD-ROM, the only other CD it came with is the Special DVD Bonus Disk, which I don't believe is needed to run the game after it has been installed.

    Any suggestions??




    System Information:
    OS Name Microsoft Windows XP Professional
    Version 5.1.2600 Service Pack 2 Build 2600
    OS Manufacturer Microsoft Corporation
    System Name JOANNA
    System Manufacturer NVIDIA
    System Model AWRDACPI
    System Type X86-based PC
    Processor x86 Family 6 Model 8 Stepping 1 AuthenticAMD ~1996 Mhz
    BIOS Version/Date Award Software International, Inc. F4, 11/6/2003
    SMBIOS Version 2.3
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\system32
    Boot Device \Device\HarddiskVolume1
    Locale United States
    Hardware Abstraction Layer Version = "5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)"
    User Name JOANNA\Joanna Carr
    Time Zone Eastern Standard Time
    Total Physical Memory 1,024.00 MB
    Available Physical Memory 571.83 MB
    Total Virtual Memory 2.00 GB
    Available Virtual Memory 1.95 GB
    Page File Space 2.40 GB
    Page File C:\pagefile.sys
     
  2. Judhudson

    Judhudson is a Hi-Tech Redneck

    You only have one disc? If that is the case, then it's a DVD, not CD. :) The CD version of the game has 4 cds.

    Here is a page on tips that *might* work for you. http://support.riverdeep.net/techtips_detail.asp?id=85

    If none work, report back and we will continue troubleshooting your problem :)
     
  3. Mirelly

    Mirelly Active Member

    Off the top of me head, this is a nit-picky issue of the game demanding the wrong type of disc drive.

    If you installed from one disc then that was a DVD, cos TS2 came on 4 CDs or 1 DVD. If you cannot fix it by following the EA Games support advice here

    Then see this page, it might help
     
  4. rockout364

    rockout364 rockout!

    The Sims 2

    I bought The Sims 2 a while ago and that is the only one I have. It only comes with The Sims 2 game disk and The Sims 2 Bonus Disk.


    ISBN # 0-7845-3555-8

    [​IMG]
     
  5. Mirelly

    Mirelly Active Member

    Yeah, it says DVD at the top. You need to follow the advice given in the two links I gave you in my last message.
     
  6. rockout364

    rockout364 rockout!

    Still having the same issue.

    I have tried most of the advice and I still seem to be having the same problem. Not sure what is wrong, I just wish I could play my game. :(
     
  7. rockout364

    rockout364 rockout!

    Unknown Application

    I was searching through the folders inside the EA GAMES folder and noticed that inside the TSBin folder and some of the other folders there are quit a few files that have an unknown application. Could that be a problem? I submitted a screen shot of what I mean...
     

    Attached Files:

  8. Mirelly

    Mirelly Active Member

    Interesting that those files are name NeroShowTimeFile?.dat

    I would uninstall the game manually:

    See this thread


    Next, before reinstalling you need to check out the way your PC is configured. I suspect that you have a DVD writer with Nero burning software and something Drive Letter Access. Now the thing is, you don't need burning software with Windows XP, which has drag and drop burning ability natively (and will Windows Media Player will even make a CD from MP3s. On the the other hand Windows is a bit crap at burning DVDs.

    The Sims 2 is not the only game that hates DLA/CD burning software.

    The simplest thing you can do is try right clicking your DVD drive in My Computer and see if DLA is an option ... if it is disable it (be warned that although this will likely fix the problem, I have no idea how to reactivate DLA after it is turned off :( )

    The next simplest thing you can try is to open Windows Task Manager [Ctrl]+[Alt]+[Del] and end the process called tfswctrl.exe if it is there.

    Neither of those is guaranteed to fix the problem.

    Another way forward, if you PC is a HP/Compaq is to run through this page

    The most reliable thing you can do is to uninstall Nero.

    Now reinstall the game ... :D
     
  9. rockout364

    rockout364 rockout!

    Nero Burning Rom: Fatal Error

    I went to Add/Remove Programs and when I went to remove the Nero Burning Rom it showed a message that said fatal error during installation! So it wouldn't let me remove it.
     

    Attached Files:

  10. rockout364

    rockout364 rockout!

    I manually uninstalled

    I manually un-installed it from my computer, and I havn't re-installed it yet.. I want to some how get rid of the Nero program but it wont let me. :confused:
     
  11. rockout364

    rockout364 rockout!

    DLA Option?

    I looked at the properties for the DVD/CD Rom drive and I could not located anything that showed a DLA option.


    And also I went to the task manager and there is no process running that is called
    "tfswctrl.exe" so that must not be an issue.


    This is getting to be tuff. LOL
    I appreciate the help a lot though, hope we can figure it out.


     
  12. Mirelly

    Mirelly Active Member

    You do need to remove the Nero if the DLA option is not available. Is there more than one user account on your computer? Uninstalling stuff like Nero should be available to administrator accounts via the add/remove programs section of Control Panel. :confused:
     
  13. rockout364

    rockout364 rockout!

    Only one user

    No I am the only user of this computer. It wont let me uninstall it, I attempted to do it manually and it is still there some how. I read another thread about NERO ... http://www.d-a-l.com/help/showthread.php?t=46553
    but still no luck with that advice also

    Do you have instant messenger because it may be easier to discuss that way if you're online at the same time.
     
  14. Leticron

    Leticron New Member

Share This Page