1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Troubleshooting Help! My sims cannot throw a Graduation Party.

Discussion in 'The Sims 2' started by hugzncuddles, Oct 23, 2006.

  1. hugzncuddles

    hugzncuddles New Member

    Help! My sims cannot throw a Graduation Party.

    Ok, I don't know if I'm missing something blatantly obvious but I haven't played Sims 2 for 5 months (until yesterday). I installed Pets over my old game (I backed it up first). I had some sims in college and just got them both to graduate with GPA 4.0. I went to the phone to throw a Graduation Party but there is no option to 'Throw Party'. I bought another phone and tried it again, but still no option to Throw Party.

    I have The Sims 2, Uni, NL, OFB and now Pets installed. No FFS or Glamour pack, but I do have the Holiday pack added.

    I'm not even sure that the problem was/wasn't there with NL or OFB as I haven't played the college town for a while. Has anyone else had this problem?
  2. jupitershana

    jupitershana Kitty Fanatic!

    I haven't had that issue, but I also haven't played my college sims yet.


    What time is it in the college lot? They can't throw a party until late morning, and not after a certain time as well.
  3. hugzncuddles

    hugzncuddles New Member

    Gahhhh I bet that's the reason. It's probably too early in the day for a Grad Party. LOL I'm sure that's the problem. I'll try that when I next play the game. Thanks so much Shana! :)
  4. jupitershana

    jupitershana Kitty Fanatic!

    Hehe, not a problem. I've had that issue before as well! Then I slapped myself in the forhead and went...it's freaking 8am, who would go to a party that early! ;)
  5. hugzncuddles

    hugzncuddles New Member

    Hehehe, well I feel really really rusty with Sims 2 at the moment. I even had to think where to put my fingers on which keys on the keyboard as I have been used to Maplestory keys for 5 months lol. I was baffled when I couldn't throw a Grad party, and I was sure it was a bug or something. It wasn't 8am as with you though, quite a bit later but I guess it was still too early in the day. :p

Share This Page