1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Troubleshooting no directx 9.0c compatible graphics adapter???

Discussion in 'The Sims 2' started by flatfishfred, Sep 18, 2004.

  1. flatfishfred

    flatfishfred New Member

    no directx 9.0c compatible graphics adapter???

    I just bought the Sims 2 today and I installed everything icluding DirectX 9. Whenever I try to start the game the sims 2 graphic appears for approx 1 second and thats it!!! finished!!!! if i disable all virus protection i then occasionally get the pop up " Failed to find DirectX 9.0c compatible graphics in the System! Please make sure you have a DirectX 9.0c compatible graphics adapter and have installed the latest drivers provided by the manufacturer."

    I can run sims 2 body shop but not sims 2 The game has been exchanged once due to the fact the first serial no. was unreadable on the instructions (all very annoying) wasted trip home and back,

    I have intel pent 4
    windows XP
    512 mb memory
    hard drive 20gb
    cd/dvd x42
    video card ge force4MX 420/440
    using driver 6.1.77 dated 15/7/04 directly downloaded from manufacturer
    previous driver NV4_disp-dll (same problem)

    I believe it to be a directx/graphics compatability, I have reduced resolution and turned off everything in sims2 read me files except adjusting bios as I cannot locate anything there to change I cannot flash up sims 2 game to reduce anything there as I've yet to see it,

    totally wasted yet another day trying to download large files on dial up

    what can i do to fire up sims 2
     
  2. ManagerJosh

    ManagerJosh Benevolent Dictator Staff Member

  3. flatfishfred

    flatfishfred New Member

    the latest drivers for the geforce 4mx is the 61.77 dated 15.7.04 which is way in advance of gefrose2 that ea recommend as basic level game playing platform
     
  4. SonnyPoo

    SonnyPoo New Member

    Same Problem

    I am having the same directx problrm and i tried to upgrade drivers but i cant get it to upgrade. This is becoming very hard.
     
  5. ManagerJosh

    ManagerJosh Benevolent Dictator Staff Member

    Post your specs up.
     
  6. Panchito

    Panchito New Member

    Hi there!

    Just got home with my new flashy Sims 2, installed it and started swearing in old forgotten languages. :p

    Ok, it installed DX9.0c on my computer (reboot) no problems. But when running the game it says the game cannot detect a DirectX9.0c compatible videocard on my system. I have tried catalyst 4.2 and 4.9.

    The system:

    Athlon 2400+
    512 MB ram
    Abit KV7 mobo
    ATI 9800pro 128


    I have tried the EA forums, but all you get there is "upgrade your drivers". Well, unless i travel in time to the future, there are NO newer dirvers. :p

    I have no problems running any other DX/OGL games. Fastwrites are off and AGP set to 4x.

    Any ideas on what could i do?

    [Repost:]
    Heh, i put a -w toggle at the end of the shortcut target and it runs in windowed mode. No sound, though. Gotta try and see if i can get it running in fullscreen.
     
  7. astaregod

    astaregod New Member

    panchito: you have an ATI card, so go to this site: http://www.ati.com/support/driver.html
    provide your operating system version and your card type and you should be good to go. also make sure you're running fullscreen mode in a resolution your card can support (might not be the problem but you never know)

    make sure you are upgrading your drivers for the correct devices (i.e. do not install a GeForce 440 driver for the GeForce FX 5200 or something like that).

    edit: josh, do you know anything about athlon's being incompatible with sims2? I remember there being an issue with bodyshop earlier in that it didn't run on machines with athlon processors. just a thought
     
  8. flatfishfred

    flatfishfred New Member

    still trying

    Glad for my sake not yours i'm not the only one going nowhere fast.

    I have down loaded the Geforce4mx 420 driver from two different web sites both ending up with the same common driver as latest available 1 took 2.5 hrs to download via dial up just to present me with the same problem, 1 seconds worth of sims2

    sorry pachito but what do you mean by -w toggle i'll try anything to get it to work, great weekend were having!!!!!!! just getting madder and madder!!!!!!!!!

    :mad:
     
  9. astaregod

    astaregod New Member

    flatfishfred: if at all possible try going back to the 61.76 version of the nvidia drivers. make sure you are choosing the correct operating system. also, after you click "graphics driver" then "GeForce and TNT2" in the driver page on the nvidia site, there is a link below called "products supported in this driver". click that and make sure the GeForce4 MX 420 is listed. also make sure you are downloading from the correct site: http://www.nvidia.com/content/drivers/drivers.asp

    the -w toggle is put in the shortcut's target location after the path to the executable. it forces the game to run in windowed mode. otherwise, the game will run in fullscreen mode
     
  10. ManagerJosh

    ManagerJosh Benevolent Dictator Staff Member

  11. Mom2Talk

    Mom2Talk New Member

    Same problem, different card... :)

    Okay... I'm having the same message coming up, but I have a different card. Below are my "specs"... Help!

    System:

    Windows XP Home Edition Version 2002 Service Pack 2
    Intel(R) Celeron (TM) CPU
    1300 MHz
    1.30 GHz, 256 MB of RAM
    Intel(R) 82815 Graphics Controller
    High (24 bit resolution)
    1024 by 768 pixels
    DirectX Version: DirectX 9.0c (4.09.0000.0904)

    Thanks a million!

    Mom2Talk
     
  12. ManagerJosh

    ManagerJosh Benevolent Dictator Staff Member

  13. Mom2Talk

    Mom2Talk New Member

    Okay... Just re-updated... Still no change...

    Okay... I downloaded the most recent driver available at that link, but I still am unable to access the program... Is there anything else I need to look into?

    Mom2Talk
     
  14. HurdleSZ

    HurdleSZ New Member

    Okay, same prob, sorta the same thing as Mom2Talk. Please help me ya'll.

    System:
    Windows XP Home Edition
    Intel(R) 1300MHz Celeron (TM) CPU
    1.30 GHz, 255 MB of RAM
    Intel(R) 8210E Graphics Controller

    Thanks!


    -----Okay, i went up to the intel download site like Mom2Talk, I havent downloaded anything yet, but when i do, i'm supposed to download a compatible graphics controller, rite??
     
  15. astaregod

    astaregod New Member

    ok, everyone who is having a problem, please visit this thread as it will assist you in solving your graphics problem (hopefully:( http://forums.worldsims.org/showthread.php?t=2874

    if you see anyone else on the forums that are having the same problems, please refer them to the thread I linked to above. thanks!!! :)
     
  16. Panchito

    Panchito New Member

    Well, for me it's NOT a driver issue. Although i agree that first thing to check are drivers, it's been stated by several people they have the latest ones and they don't help, so bashing the same solution over and over isn't helping them.

    I got a hint in other direction, though: refresh rates. If you have a program//utility that locks your refresh rates, it might conflict with the Sims 2, which for what i've heard is designed to run at 60Hz and won't accept anything else other than that. Quite a bad decision, if you ask me.

    If you have programs like Reforce, RefreshForce and similars, or even a driver setting locking your refresh rate, you might want to try turning them off so the Sims 2 has freedom to set the Hz to whatever it wants.

    Source.
     
  17. astaregod

    astaregod New Member

    Panchito: is there such a program on your computer that will lock refresh rates? I don't think that an error message saying something about a DirectX9.0c-incompatible card exists in the system would come up because of a refresh rate problem. But anyway, my refresh rate is at 75Hz so I might have problems running the game too (I get it tomorrow). I'll post here about what I encounter.

    Everyone else, if you have tried what I suggested in the thread linked to in my previous post and you are still having problems, try checking the refresh rate and post what it is. Thanks. :)
     
  18. kristygal

    kristygal New Member

    I'm unfortunately getting the same "no directx 9.0c compatible graphics adapter" error message and after spending 2 hours on the phone with HP tech support, I'm ready to give up and sell my game. My last resort is to call EA monday but I've heard they're worthless. I've tried every step that has been posted on this forum and gotten nowhere. Maybe someone has an idea before I give up and put this game on ebay. :confused: Here's my system:
    HP Pavillion A282n
    2.40 GHz Intel Pentium 4
    512 MB DDR SDRAM
    80 GB Ultra DMA hard drive
    Intel Extreme Graphics 2 82865G controller
    64MB shared video memory
    Thanks in advance.:)
     
  19. astaregod

    astaregod New Member

    kristygal have you tried the suggestions in the thread http://forums.worldsims.org/showthread.php?t=2874 ? After you do (or if you did already) and it still doesn't work, post your refresh rate. You can get this by going to display properties, going to the settings tab, clicking the Advanced button, then clicking the monitor tab. Under "screen refresh rate" it will show your refresh rate. Post that and we'll try to help you as best we can.

    I followed the link that Panchito posted earlier (http://www.rage3d.com/board/showthread.php?p=1333186422&posted=1#post1333186422) and it very well may be the cause to your problem running the game.
     
  20. kristygal

    kristygal New Member

    My screen rate has "60" highlighted in the box, but if you click on the arrow on the right it has listed 70, 75 & 85. As you can tell, I have no idea what these mean! :eek:
    I'm going to check out the link you posted next. THANK YOU SO VERY MUCH!!!!!
     

Share This Page