1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SimCity Societies SimCity Societies not starting

Discussion in 'SimCity Legacy' started by kristinaaaaa, Jan 19, 2010.

  1. kristinaaaaa

    kristinaaaaa New Member

    SimCity Societies not starting

    I downloaded SimCity Societies on my Vista system through the EA download manager and installed it without apparent issues, however it won't do anything when I try to run it.

    How can I fix this? I don't want $20 to go down the drain.

    Thanks :)
     
  2. Caledo

    Caledo New Member

    I've the same problem! I bought SCS through EA and, after the installation, it did't run... I have XP...
     
  3. swmeek

    swmeek I got your benevolent dictator pal!!

    If you're running the digital download version it might be because the anti-piracy protection is conflicting with something you have installed and then again your system may not be able to handle it.
    Any computer should install just about any software provided it's PC-PC or MAC-MAC software but that doesn't stop it from not running it.
    It use to be you'd install a program and it would tell you if it would work or not depending on the hardware you had installed but nowadays that's just an old dream.
    Companies are too greedy to do something that might stop them from making a buck or $50 for that matter.
    If you could post your dxdiag report it would help us determine if it's a possible hardware or software problem.
    Click the start button and you should see the "run" option.
    Click it and type in the box dxdiag and click ok.
    Let it run (you should a green progress bar at the bottom while it does it's thing ) and when it's done click the save all information and save it somewhere you can find it.
    You can either copy and paste the text to your reply or attach the dxdiag report to your reply by clicking manage attachments and upload it here.
     
  4. scubatex

    scubatex New Member

    Same issue.

    Downloaded on line and it will not start.
     

    Attached Files:

  5. kevwal1

    kevwal1 New Member

    All,

    I have the same issue. Purchased and downloaded via the EA store. I run XP with Directx 9c installed (confirmed by dxdiag) and I keep the drivers on this system up to date.

    Any suggestions or solutions?

    thanks
     
  6. liam_clarke

    liam_clarke New Member

    I have this problem too..... I downloaded it through the EA store, I really dont want to waste £15! I run vista with dx9c.... I click on the icon, and then it looks like it is loading because the mouse has that little loading spinning circle, then it just disappears and nothing happens :(
     
  7. jaclyn.lewin

    jaclyn.lewin New Member

    Hi I saw thqt you can help with simcity societies....i have windows vista and a brand new computer and it wont work!
    I did the diagnostics run can you help me my email is jaclyn.lewin@gmail.com
     

Share This Page