Troubleshooting Sims 2 won't start anymore

Discussion in 'The Sims 2' started by MysticalNights, Aug 4, 2007.

  1. MysticalNights

    MysticalNights New Member

    Sims 2 won't start anymore

    Hi all. I am one VERY frustrated person. I live thru my sims and now I can't get the rotten thing to start up! I am running XP and have installed The Sims 2, University, Nightlife, Open for Business and Family Fun Stuff.

    One minute I was able to play the game and then I looked for some new objects to install. I stuck to the legit ones (only recoloured items and the such). Now when I go to start the game I get as far as "Crenellating Crenellations" and then the whole thing just freezes! When I look at the task manager it tells me that it is no longer responding!

    Has anyone else had this problem, and if so, HOW THE HECK DO I FIX IT!?!?!?!?!?! This is most frustrating. I even tried using the "-nosound" toggle, as this worked for The Sims 1, but still no go. I'm dying here, please, someone, HELP!!!!

    Nomes
  2. dangerousgem

    dangerousgem New Member

    Try taking out your downloads folder and see if the game loads up ok without it.
    Just move the whole folder to your desktop.
    If it loads ok without it then you've got a bad download and you'll have to start sorting through them by putting only a handful of the files back in at a time to find the problem file.
  3. MysticalNights

    MysticalNights New Member

    I was afraid of that

    Thanks for taking the time to help me with this issue. I had a horrible suspicion that that was going to be the suggested solution. I am actually in the middle of trying this and will let you know whether or not it helps. I have also updated my video card drivers as well.

    Again, thanks heaps

    Mystical
  4. MysticalNights

    MysticalNights New Member

    Well, I removed all the downloads from the folder and guess what. Nadda! The first time I was able to get a little further, so I rebooted the computer, but sure enough same problem, same place! HELP! Please!

    Here is the low down on the comp as needed;

    PROCESSOR: AMD Sempron Processor 2600+, MMX, 3DNow, ~1.6GHz
    SYSTEM MEMORY: 256 MB RAM
    WINDOWS VERSION: XP Pro 5.1 Build 2600
    FREE HD SPACE: 5.49 GB
    TOTAL HD SPACE: 37.2 GB
    DIRECT X VERSION: Direct X 9.0c
    DISPLAY ADAPTER: NVIDIA GeForce 6600GT
    ADAPTER DRIVER DETAILS: nv4_disp.dll 6.14.0011.6218 29th June 2007
    APPROXIMATE TOTAL VIDEO MEMORY: 128.0 MB
    GAME DETAILS: Sims2 DVD, University, NightLife, Open for Business & Family Fun Stuff
    NATURE OF PROBLEM: Won't load past "Crenellating Crenellations"
  5. Odinmoon

    Odinmoon Creator of organised mess

    Try renaming My documents/Ea/sims 2.
    The sim 2 folder and start the game and see if it starts.
    Then tell us if it did and we go to next step.:)
  6. MysticalNights

    MysticalNights New Member

    Well, that didn't work!

    I tried renaming the folder, but no progress, in fact, probably went backwards! I have also upped my free HD space to 17.18GB and defragged the computer. Any other suggestions? :rolleyes:
  7. dangerousgem

    dangerousgem New Member

    Try deleting these files: Accessory.cache and Groups.cache
    They can be found in C:\Documents and Settings\*****\My Documents\EA Games\The Sims 2.
    Don't worry the game will make new files to replace these ones.
    This seems to fix a lot of loading problems with the game.
  8. Mirelly

    Mirelly Active Member

    Those files would have been unavailable anyway if the EA Games\The Sims 2\ folder was moved.

    I'm not happy with the renaming option. I recommend physically moving the folder from My Documents to the desktop ... making absolutely sure that that there is no folder containing any Sims 2 files in the My Documents\EA Games\ folder before trying to reload the game.

    I am afraid that if that doesn't work then you should undertake a full manual uninstall followed by a careful and systematic reinstallation (keeping your original file folder on the desktop until you have completed reinstalling all the expansions.

    Do not uninstall until you have located ALL the registration codes. If you are missing any we can point you to the loaction were they are saved on your computer before you uninstall.

    See the FAQs for the how to manually uninstall (which makes sure that all the important registry keys are removed before you start trying to install again.
  9. gill2002

    gill2002 New Member

    Me Too

    I am having the same problems. I have downloaded stuff and it worked then i downloaded a bit more and now i get as far as the 'preparing bacon@ bit and it stops. I have to restart comp as nothing else works.
    Will let you know if anyone answers my problem.
    gill
  10. Lynet

    Lynet New Member

    Hi, Gill2002.

    The first thing I'd try is to just drag the Downloads folder to the desktop and see if the game starts up without it.

    If that doesn't work, read Mirelly's post and go from there.

    Hopefully, moving the Downloads folder will do the trick. If it does, then you only have to test your downloads to find the bad one.
  11. Peati

    Peati Mountain Biker Maniac

    If all else fails you can always uninstall / reinstall everything. It may be a pain in the butt, but at least you might be able to play it again. Just back up your files first! Otherwise you will loose all of your familes...;)
  12. strangeaslife

    strangeaslife New Member

    Can you give details on how to back up these files so families wont be lost?
  13. swmeek

    swmeek I got your benevolent dictator pal!!

    Google the Sims2 Wiki as you'll find details on how to back up your game.
  14. molloy evan

    molloy evan New Member

    yeah im having the same problem with my sims!!!! university expansion thingy lol ive installed it properly and when i try to start it it shows the splash sayin sims 2 uni but after that.....nothing but my iron maiden wallpaper........can someone plz tell me how i can fix this?
  15. Kiana777

    Kiana777 Jr. Member's Darkness

    MysticalNights? Hi...I'm new...but I have the same problem!! It was working fine, started, and I played for hours...I had about 750 downloads a few days ago, and I was happy, it still worked perfectly fine, I dowmloaded a mesh for some horses I downloaded, aswell as other things, so I probably have just about 1000 downloads...(lol--x_x) When i went to open it, it did load, but it stopped at Crashproofing Parties, and freezed!! (just like yours) I had to restart the computer because it wouldn't close (I tried Ctrl+Alt+Delete, Alt+ F4, Esc, Alt+Tab) and this is really annoying...BUT! It did the same thing upstairs, where there aren't ANY downloads, and same thing...again, BUT! My grandpa picked the disc up, and dropped it with no care, no worries of it being wrecked, he just dropped it..and after that, it stopped working...Would that spray stuff to get rid of scratches on discs work? My g-pa has a mini bottle of it....

    Can any of you help me? I WILL try the downloads thing, but anyway to fix the 'disc'??? And I only got it---maybe 3-5 months ago...
  16. GeorgiaOx

    GeorgiaOx New Member

  17. Moo_Cow

    Moo_Cow New Member

    my sims is doing this aswell its driving me mental is there any way of polaying it online insteadd because i just cant get it to load!!! ::)mad:(n):cry:
  18. swmeek

    swmeek I got your benevolent dictator pal!!

    no there's not.
  19. cmderoca

    cmderoca New Member

    dont delete the downloads "folder" but delete what's inside on that folder.. ;) definitely the game will work again :))
  20. KatAnubis

    KatAnubis Lady Staff Member

    Of course, you'll have to replace all your downloads then. It's best to use something like the Clean Installer to figure out which piece of download is corrupted.

Share This Page