Troubleshooting Sims 3 won't start up!

Discussion in 'The Sims 3' started by rainbow_dash, Jun 17, 2009.

  1. rainbow_dash

    rainbow_dash New Member

    Sims 3 won't start up!

    So, i installed the sims 3 on my pc..
    All went well and such.. i click the launch shortcut on the desktop, the window opens just fine, but then i click the arrow button to play, it begins starting and it gives me a black window like when it's about to start up but then it closes and nothing happens!!! No error or anything.. it looks like if i had closed it.
    I have all system requirements. My sister installed it just fine on her pc and it works.. the only difference between our pcs is that hers has a little more space and it doesn't have the sims 2 installed while mine still does. Could this be it?
    Both are windows xp, btw.
  2. swmeek

    swmeek I got your benevolent dictator pal!!

    we would need to see your dxdiag report please to help you .
    click the start button and right above it you will see "run"
    Click that and in the box type in dxdiag and click ok.
    when it's done click save all information and save it to your desktop.
    Now you can either attach that file with your next reply or open it up and copy and paste the text into your reply.
    janci likes this.
  3. janci

    janci New Member

    i have the same problem can jo help me
  4. KatAnubis

    KatAnubis Lady Staff Member

    Please post your diadx so that we can help you.
  5. Sophia Clarice

    Sophia Clarice New Member

    That happened to me, but I uninstalled the game (but not the saved games) and then reinstalled it and then it worked for me.
    ManagerJosh likes this.
  6. mhugh

    mhugh New Member

    Mine won't start up either but I have a Mac. When I go to play it, it opens up to the home page but then I have to download an update if I want to play, if I select 'no', it just shuts down. Every time I do it, it opens up the screen you get when you install things from the Sims Store and it says 'an unknown error has occurred... and shuts down. It worked on this computer before but then I changed the settings around and now it doesn't start. I tried not downloading the update before installing an expansion pack, but the same thing happened. What do I do? I am thinking it is something to do with my settings.
  7. Nyx

    Nyx The Ever-Knowing

    Have you tried uninstalling the game? Save your saved games and or sims too in another folder if you want to keep them.
  8. mhugh

    mhugh New Member

    I have uninstalled it and re-installed it a few times now and i don't know what else to do.
  9. ViennaBrielle

    ViennaBrielle New Member

    I have the same problem. Just as described above, I hit the play button on the little start-up window and it seems like it's going to load up, with the black screen, but then I hear the error sound and then it's just black for awhile. I uninstalled and reinstalled twice now. I have no idea what to do.

    DxDiag:
    Time of this report: 6/8/2011, 10:32:04
    Machine name: USER-D78E04A4A8
    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.101209-1647)
    Language: English (Regional Setting: English)
    System Manufacturer: System manufacturer
    System Model: System Product Name
    BIOS: BIOS Date: 01/30/08 10:01:36 Ver: 08.00.10
    Processor: Intel(R) Core(TM)2 Duo CPU E7200 @ 2.53GHz (2 CPUs)
    Memory: 1024MB RAM
    Page File: 794MB used, 1652MB available
    Windows Dir: C:\windows
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: None
    DxDiag Version: 5.03.2600.5512 32bit Unicode

    I hope that's what you needed.. Thank you!
  10. swmeek

    swmeek I got your benevolent dictator pal!!

    Could you please post the video card information as well?
    Is this a laptop or desktop computer and have you checked to make sure the computer is not overheating by making sure the fans are all working properly/not plugged with lint/dust bunnies/ or use a laptop cooler if it's a laptop.
    Also when was the last time it worked or is it a new install and what have you done to the game since it worked correctly?
    Any new custom content/ stuff packs or expansion packs?
  11. ViennaBrielle

    ViennaBrielle New Member

    Off-hand I have no idea what the video card is, I'll have to do some research and maybe take my computer apart to look at the pin number and all that. I know that my computer isn't over-heating. At least, I imagine it wouldn't be. I've played Sims before and it has never over-heated. So it worked the last time I played, which was probably.. oh.. a few months ago. It worked fine. Now I started it up put the update on it, and it does that black screen with error sound.

    I don't have any custom content or expansion packs.
  12. KatAnubis

    KatAnubis Lady Staff Member

    You don't need to take your computer apart to find out which video card you have. Just run a dxdiag. It's one of the things listed.

    If it worked prior to an update, then you may need to update your videocard driver or reinstall the game and updates. There have been some problems with the update and although I haven't heard yours mentioned specifically, it wouldn't surprise me. (Also, make sure you don't have any old mods installed as that can cause the problems you mention too. It's best to make sure to remove all mods before updating your game.)
  13. mhugh

    mhugh New Member

    It was not working on my computer originally so I always used another computer in my house to play Sims 3 on. I swapped computers to the one it was working on and it happened again. I have checked, it is not the computer, but I think it is something to do with my settings... I wouldn't have a clue what though. If you would like, I can post all of the details about my computer if that will help.

Share This Page