1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Troubleshooting Adoption Problem - baby never shows up!

Discussion in 'The Sims 2' started by Ninotchka, Nov 15, 2005.

  1. Ninotchka

    Ninotchka New Member

    Adoption Problem - baby never shows up!

    Hi all.

    I'm new here and although I've been playing my Sims 2 game for about six months, I've never encountered such a problem.

    So, OK, I have a couple and they get approved for adoption. When the day comes, the little screen pops up asking me what I want, and I click on "infant" or "baby" or whatever...

    so far so good

    the day then comes and goes when the baby is supposed to arrive and it never does.
    I've tried calling the adoption agency again, go through getting approved, selecting "infant" again and NOTHING.

    WHAT GIVES? :confused:
     
  2. MegRen

    MegRen New Member

    Don't you have to wait until the social worker arrives before choosing what age child you want? That's how it works in my game.

    As for your problem, I have no idea. Have you installed any hacks or mods? They may be causing the problem.
     
  3. Ninotchka

    Ninotchka New Member

    the game asks me what I want without a social worker being there.

    I also have not installed any hacks or mods.
    Maybe I just need to bulldoze and start over?

    So frustrating. :cry:
     
  4. felicity1986

    felicity1986 New Member

    Adoption Problems

    I also have the same problem and I need help with that! What's going on?

    The social worker doesn't show up, just the car. And then the car just slips by! What gives?

    PLEASE HELP US!!
     
  5. Lynet

    Lynet New Member

    Is anything blocking the road or the house? The maid? The gardener? They always park their trucks across the street and, if I recall, so does the social worker. And they all show up about the same time in the morning.
     
  6. felicity1986

    felicity1986 New Member

    Tried it, but still doesn't work!

    I fired the maid and the gardener left before 10am, but still the baby never showed up. The social worker never got out the car. There will just be a window that pops up asking me to pick either a baby, toddler or child, a car shows up then disappears in a second. The baby never shows up, what's going on??

    PLEASE HELP!
     
  7. Shintoga

    Shintoga Student of Simlish

    Don't know if this will help, but...

    • Family funds must exceed $3000 to adopt
    • Calling sim does not have Memory of having a kid taken away by Social Worker - baby, toddler or child
    • Family size must be less than 8 (which goes without saying anyway...)
    • A Sim (adult or elder) needs to be at home when the kid arrives (again, pretty obvious)
    Apart from this I can't think of any reasons (aside from hacks) that would be causing this problem, but I hope you manage to get it sorted!
     
  8. felicity1986

    felicity1986 New Member

    Still won't work

    I've done all that but it still doesn't work

    1) Money over 300,000

    2) Calling Sim have been the Oldies (married) and 1 Sim who is single.

    3) Family size: 3

    4) Always people present when social worker appears.

    Please help!!!
     
  9. Lynet

    Lynet New Member

    Ah, felicity1986 ---

    Is it just the one household or have you tried adopting in other households and it didn't work there either?

    If it's just the one household, the lot may be bugged and you need to move them out and into a new house. Don't try moving the whole house, family and all, because if the house is bugged then you need to separate the family from that house and lot.

    It's also possible, if it's just this one family, that the family itself is bugged and moving them around won't help. I had a bugged family. It's depressing, but it happens because the game is extremely complex and sometimes the code gets tangled up. :(

    If it's a problem with all households in your game then that's a problem too big for me.
     
  10. felicity1986

    felicity1986 New Member

    It's a problem for all households~~~

    Well, I tried 2 lots, but still the social worker won't show up.

    Please help!
     
  11. Lynet

    Lynet New Member

    Trying, trying :( . How about more details --

    As in: Cheats used (for example aging on/off)? Other problems with the game? Uni loaded? Nightlife loaded? Hacks downloaded? Anything else downloaded. Did adoption work before but not now? Have any of your households had babies without adopting?

    Anyhow, you see what I mean about some details.
     
  12. felicity1986

    felicity1986 New Member

    More details

    Well, the fact is I downloaded Sims 2 before and it worked perfectly fine in the first place. I got Cassandra Goth to adopt a baby, then it got taken away by the social worker. Then I downloaded some more objects from websites, but found that they were not so good. So I completely uninstalled the Sims2 and reinstalled the Game.

    This time, I never downloaded a single object, don't have Sims 2 Uni or Sims 2 Nightlife. Tried to use the adoption service for couples.

    But it just won't work and tried 2 families.

    The Aging is off.

    I don't have any hacks or mods. Basically, I avoid downloading stuff now in case they corrupt the game.

    Well, adoption service worked when I FIRST installed the game, but after my 2nd installation, the problem occurs (and mind you, I have no downloads).

    Well, female Sims in other households are pregnant, not sure if they'll really have a baby coz I heard some people have experienced disappearing babies once they're born.

    Thanks.
     
  13. Lynet

    Lynet New Member

    Just making sure, because some people use the words download and install as if they meant the same thing, but pirated games always have problems. So assuming you meant installing a game you bought ...
    Try turning aging back on. Others have experienced problems with children when aging is turned off.
    There is a patch available for the original game. You can download it from the official EA Sims2 site. It is supposed to fix the disappearing babies problem. I had to get it but I'm not sure now where it is located at the EA site since the patch was probably included in the expansions. Before downloading the patch, however, copy your neighborhood files somewhere else, like to your desktop, for safekeeping in case of problems. Do a search on this forum for "how to"s on patch and expansion installation, just to be sure it all works OK for you.

    Try these suggestions and good luck.
     
  14. felicity1986

    felicity1986 New Member

    Well

    Well, the thing is the Aging is on.

    But still adoption service won't work.

    Please help as it didn't happen in the first place.

    Plus, the content manager just won't run on my computer. I can download it, but when it comes to operating it, I double-click on exe and nothing pops up. Please help!
     
  15. Oddyssey

    Oddyssey New Member

    I had this issue with the baby never showing up. In fact, the social worker never showed up either. They said they'd come at 10am, but days later, still no baby. So, I used the "boolprop testingcheatsenabled true" cheat and used the "Tombstone of L and D" to make one of the social workers part of the family. Then, once the social worker was "Selectable" all of a sudden, out of nowhere, another social worker (actually, the same one I made part of the family) showed up with my child to adopt! Well, then I unfortunately had to kill off the social worker I made part of the family, but she served her purpose and now we have a wonderful little toddler boy!

    Hope this might help someone else who's still playing the Sims2!
     

Share This Page