Troubleshooting no directx 9.0c compatible graphics adapter???

Discussion in 'The Sims 2' started by flatfishfred, Sep 18, 2004.

  1. Panchito

    Panchito New Member

    Happens in Full Spectrum warrior and in Battlefield too, for what i've heard. It's not what you have your refresh rate set to in the drivers, the problem is if you *force* it thorugh a third party program (if not, windows adapts the refresh rate to whatever, unless your drivers have a special feature to lock the refresh rates. Beats me why would anyone want to program things in such a way.
  2. astaregod

    astaregod New Member

    yeah, I'm asking if there is a third-party program on your computer that is forcing a refresh rate other than 60Hz. Hit Ctrl-Alt-Delete (and if you're in win2000 or winxp, click the processes tab) and end all background tasks except explorer and systray (for win2000 and winxp end just about everything that has your user name next to it in the user name column except explorer.exe) and try to run the game in fullscreen mode.

    if you're running it in windowed mode does the game adapt to the current refresh rate and would it matter since it's in a window? just something to think about
  3. Panchito

    Panchito New Member

    You've got a point there about window refresh rates (yes, i am running MultiRes as a service, i'll unregister it when i'm at home tomorrow). However, as noted, i have tried different drivers, and currently running the latest ones and it's not working in full screen anyways. Other people with the save videocard and drivers can play no problems, though, so i guess it must be something different. BIOS is configured to maximum compatibility mode. Will see what comes out of this refresh think, and if it turns out to be something different, try to root what it is.
  4. Panchito

    Panchito New Member

    Ok, i've found the problem: The Sims 2 refuses to run in full screen when my desktop resolution is higher than the game's resolution. My desktop is usually at 1280x960. I set the game to 1024x768 in windowed mode, then got back to the desktop and set it to 1024x768 and then ran from the fullscreen link. Blam! It runs perfectly.
  5. astaregod

    astaregod New Member

    ALRIGHT!!! it does seem like a weird error but WOW it works now!!! I bet you're really happy!!

    Maybe you can answer this because I don't have my game yet: the sims2 will run at a resolution of 1280x1024 right? I just don't wanna change my screen resolution every time I run the game :)
  6. Eric444

    Eric444 New Member

    im getting the same error i did all the the steps in other theards but its still not working
    my specs are
    Dell Optiplex GX 150
    intel pentium3 1.0ghx
    memory 254 mb ram
    intel 82815 graphics controller
    chipset 82815
  7. ManagerJosh

    ManagerJosh Benevolent Dictator Staff Member

    For one Eric, your system doesn't even meet the minimum system requirements.

    Have a look at them :)
    http://forums.worldsims.org/showthread.php?p=35763#post35763
  8. Sims2KidsMom

    Sims2KidsMom New Member

    compatible graphics adapter

    I am unable to get the game to load on the following computer, I've gone to the S3 website and downloaded and installed the latest drivers available. What to do at this point? Do I need to buy another video card or will this one somehow upgrade to work??? Help!!!
    Operating SystemMicrosoft Windows XP Home Edit! ion (Bu ild 2600)PassWindows XP/2000/98/MESystem Memory480.5Pass256.0Processor Speed1466.7Pass800 MHzDirectX Version9.0cPass9.0cDisplay DeviceS3 Graphics ProSavage CompaqUnknown CompatibilityDisplay Memory64.0Pass32.0Display Driver6.13.10.1012-13.90.10.1Unknown CompatibilitySound DeviceSoundMAX Digital AudioPassSound Driver5.12.01.3030Unknown Compatibility
  9. curtisu

    curtisu New Member

    Same directx compatability problems as mentioned. I'm not in front of the machine I'm running(not) Sims2 but I do remember it's a 900Mhz Pentium and uses an Intel 810 chipset graphics controller. And I've got the latest driver as of this morning.

    I plan to try following the "Josh thread" of moving that file around when I get the chance.

    Something that confuses me is that I passed the DX tests, white/black squares, bouncing squares and logo etc. I'd have thought that passing the tests means there is directx compatability... dunnit?
  10. Whiteknight

    Whiteknight New Member

    how do i start the game in windowed mode?
  11. sha_bang

    sha_bang New Member

    Mine passed the test too and it says I have DirectX 9.0c, BUT for everything else it says unknown. Anybody know what I can do??
  12. Lee

    Lee New Member

    directx 9.0 problems

    I have the same directx 9.0 error message & I tried everything that was suggested & still nothing.Please help me,I wanna play my game
    :(
    Heres my specs:
    Computer PBN_Computer
    Microsoft Windows 98SE
    BIOS AMI
    Processor intel celeron 600MHz
    Memory 318MB RAM
    DirectX version,directx 9.0c
  13. Vchat20

    Vchat20 New Member

    alot of you here seem to be way below the system requirements and may be the reason why the game wont run. i dont have a link offhand, but maybe someone else can provide one. but check your system specs against the minimum requirements and see if they are up to spec.
  14. lexie1107

    lexie1107 New Member

    Problem...

    I don't have internet on my gaming computer. And I don't know what now. *grr*

    My "specs"=

    operating system: Windows ME (4.90, build 3000)
    system manufacturer: Hewlett-Packard
    system model: HP vectra
    bios: default system BIOS
    processor: intel pentium 3, ~450 MHz
    memory: 128MB RAM
    direct X version: direct x 9.0c
    High (24 bit resolution)
    1024x768


    I think thats all that's needed.
    I'm so confused.
    I also tried to do this:

    click start
    click run
    type "dxdiag"
    and then I made sure the three things were enabled

    And it didn't work.

    Help please and thanks in advance.
  15. J. M. Pescado

    J. M. Pescado Fat Obstreperous Jerk

    Is your problem specifically the "No DirectX 9.0c compatible graphics adapter" error? Under the assumption that you are not an idiot and have, in fact, installed all of the relevant drivers and DX9c as is required, do the following:

    Run DXDIAG: Flip over to the display tag, and run all of the Direct3D tests. If the DX9 test completes successfully, then I'm baffled. If, however, the test FAILS, or is SKIPPED, please check, still under the "Display" tab, the section marked "Drivers". What does it say for "DDI Version"? The correct response SHOULD be "9 (or higher)", but it could potentially erroneously say 7 or 8. This is bad, and is what is causing your problem. If this is the case, indicate so here so I can walk you through the voodoo debugging solution.
  16. lexie1107

    lexie1107 New Member

    It says 8.

    It says 8 on ALL FOUR computers I tried this dumb game on.

    This is very frustrating.

    And yes, it does do the 9 test, and perfectly fine.
  17. J. M. Pescado

    J. M. Pescado Fat Obstreperous Jerk

    Well, try out the voodoo debugging solution I sent you. You may also want to lose WinME. WinME is crap.
  18. lexie1107

    lexie1107 New Member

    new computer, same problem....

    Well... this is the computer I have it on right now. WinME was not working.

    At the moment I am using XP.

    Edit 1: new specs are:

    Operating System: Microsoft Windows XP Professional (Build 2600)
    System Memory: 127.2
    Processor Speed: 797.4
    DirectX Version: 9.0c
    Display Device: Intel(r) 82810E Graphics Controller
    Display Memory: 32.0
    Display Driver: 5.13.01.2753.1-Intel Integrated Graphics
    Sound Device: SoundMAX Digital Audio
    Sound Driver: 5.12.01.3508

    And this computer is a Dell OptiPlex GX110 With a pentium 3 processor... 800 GHz
  19. banditseys

    banditseys New Member

    That is exactly what happened to me. I was going to post this but sionce it is now posted I suggest you do as ^^^^. My graphics card was "apparently" correct, however I finally found the Direct CD8 problem. My graphics acrd had no newer drivers so I got a new one.
  20. ndnhottie79

    ndnhottie79 New Member

    DirectX9.0c problems.

    My system says DDI 8, can you send me the debug thing also?

Share This Page