1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sims Mega Deluxe won't install on second go .... HELP!!

Discussion in 'The Sims 1' started by Micwlf, Sep 24, 2015.

  1. Micwlf

    Micwlf New Member

    Hi, I own the Sims MegaDeluxe with the expansions HotDate, HouseParty, LivingLarge & I also have the expansions, Vacation, Unleashed, & MakingMagic. I had the games installed and all worked fine. I just got Unleashed and MakingMagic so I haven't even gotten a chance to try them yet! I got the update on my computer that says, "Try Windows 10" so I tried it. Well, my computer's on the 'low' end so I really didn't care for the update. So I reverted back to Windows 7 Professional, which is what I was running originally when the games worked. I tried to play the games which had worked before just fine and it wouldn't work. I tried uninstalling and re-installing and no go. I recently bought Unleashed & MakingMagic and thought I would try again. I even went into the registry like another thread on here says and uninstalled everything, removed the keys, etc... Then I try to re-install and no go. It gets to a file called Data3 and then the drive spins and spins. I have let it go for over an hour and no it wouldn't work. I have seen several other posts throughout the internet saying that other people have this same problem and yet no way to correct this where my games will work again. I have tried copying the files to my drive, and that stupid file makes it freeze every darn time! I even tried an ISO imaging program and tried to make a disk image, thinking I could possibly set up a virtual drive and that would work. Guess what.... that data3 file... Is there no answer to be had?? I can't play the newer versions on my crappy computer and I rather liked the older ones anyway! I even called EA Games and I got a really rude employee who first says, "That's NOT a Video Game! It's too old to be a video game!" I'm like "What the heck does that mean?!" then he says that, "NOBODY plays that anymore and it is OBSOLETE therefor we will not provide any support information" Reallly Helpful...NOT! I am very frustrated... my discs are all good, no scratches. What can I do now??
     
  2. KatAnubis

    KatAnubis Lady Staff Member

    Have you tried using compatibility mode? TS1 was not ever meant to run on Windows 7. Windows XP was a bit of a stretch at times. However, if you were running it on Windows 7 at some point, I suspect you had it in compatibility mode to do that but don't have it on since you reinstalled the game. But you can still put it in compatibility mode. Unfortunately, although I've seen the instructions for doing it many times on the TS3 boards (because people still occasionally need to do that), I don't remember how it's done. Good luck! I hope you can get it to work!
     

Share This Page